Community Support system issue

Incident Report for PayJustNow

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 15:55 CAT

Identified

Our service desk is temporarily offline as our service providers investigate the issue. At this time, the portal, and email support channels are unavailable. Our Chat function is online. We appreciate your patience and will provide updates as soon as more information becomes available.

Thank you for your understanding. 🙏
Posted Feb 17, 2025 - 11:13 CAT
This incident affected: Support Platforms (Email).