Community Support System Recalibration

Incident Report for PayJustNow

Resolved

Our live chat is online.
Posted Apr 04, 2025 - 09:32 CAT

Monitoring

Heads up 👋

Our live chat is currently offline and will be back at 09:30.

In the meantime, feel free to drop us an email at support@payjustnow.com—we’re here to help and will get back to you ASAP.

Thanks for your patience!
Posted Apr 04, 2025 - 08:39 CAT
This incident affected: Support Platforms (Chat).