Heads up: The ACS in-store Point of sale network is having a moment.

Incident Report for PayJustNow

Resolved

All clear—transactions are back on track.

The earlier connectivity issue affecting our point of sale network has been resolved. ACS have confirmed the fix, and we’re now seeing successful transactions across all previously impacted retailers.

Thanks for your patience while we got things sorted. You’re good to go!
Posted Apr 19, 2025 - 13:07 CAT

Identified

We’re currently experiencing connectivity issues with the network that powers some of our in-store point of sale integrations. This might affect your ability to complete transactions at checkout at all stores that make use of the ACS network.

Their teams are already on it and working hard to get everything running smoothly again. We’ll keep you posted with any updates.

Thanks for bearing with us—we’ve got your back.
Posted Apr 19, 2025 - 10:17 CAT
This incident affected: Checkout.