Support Mail Downtime

Incident Report for PayJustNow

Resolved

This incident has been resolved.
Posted Sep 14, 2025 - 18:08 CAT

Monitoring

We are currently migrating our support email. We do not anticipate any downtime but if you cannot get through to the support team viea email please start a live chat.
Posted Sep 14, 2025 - 17:33 CAT
This incident affected: Support Platforms (Email).