We are continuing to monitor for any further issues.
Posted Aug 22, 2024 - 17:01 CAT
Update
We are continuing to monitor the services, but stability appears to have been achieved. Thank you for your patience.
Posted Aug 22, 2024 - 17:00 CAT
Monitoring
We have identified the root cause of the earlier reported degradation in our services related to Amazon Web Services (AWS). We are now seeing improvements across all affected functionalities, including Sign Up, Checkout & Payments, and Selfie Verification. Users should begin to experience normal performance levels, but there may still be occasional slowness as we continue to stabilize the service.
Our team remains closely engaged with AWS to ensure that performance is fully restored to optimal levels. We continue to monitor the situation very closely and are committed to ensuring the reliability of our services.
Next Update: We expect to resolve the issue fully soon and will provide a final update in the next hour or as soon as all services are confirmed stable.
For ongoing updates, please subscribe to our Status Page.
We appreciate your continued patience and apologize for any inconvenience this may have caused.
Posted Aug 22, 2024 - 15:30 CAT
Identified
We apologise for the inconvenience caused, For real-time updates, please subscribe to this status alert to hear when you can continue with your purchase or sign up.
Posted Aug 22, 2024 - 14:31 CAT
Investigating
We are currently experiencing performance degradation with our services due to issues with Amazon Web Services (AWS). This has impacted several of our key functionalities, including Sign Up, Checkout & Payments, and Selfie Verification processes. Users may experience slower response times or intermittent errors.
Our engineering team is actively working with AWS to resolve the issue and restore full functionality as quickly as possible. We apologize for any inconvenience caused and appreciate your patience during this time.
Posted Aug 22, 2024 - 14:30 CAT
This incident affected: SignUp, Checkout, Core Switching and Merchant Platforms (PayUp APP, Merchant Portal).