All hands disruption

Incident Report for PayJustNow

Resolved

All support channels are back online. Thank you for your patience.
Posted Sep 16, 2024 - 13:21 CAT

Identified

Our support channel will be temporarily unavailable today from 1:00 PM to 1:30 PM due to an all-team meeting as we prepare for the upcoming Peak Season. For assistance during this time, please email us at support@payjustnow.com. For partner support, please log in to the support portal and create a ticket.

We will resume responding to chats after 1:30 PM. Thank you for your understanding, and we apologize for any inconvenience as we build a better PayJustNow and position the team to be there for you where it counts, this peak season.
Posted Sep 16, 2024 - 12:18 CAT
This incident affected: Support Platforms (Chat, Email, Phones).