Bankserv MasterCard processing systems reporting intermittent degraded performance issues

Incident Report for PayJustNow

Resolved

MasterCard Payments Issue Resolved: The recent problem causing some 3D Secure MasterCard payments to decline intermittently has now been resolved. BankServ has completed their investigation and everything is back to normal.
Posted Oct 24, 2024 - 15:57 CAT

Monitoring

MasterCard Payments Issue Resolved: The recent problem causing some 3D Secure MasterCard payments to decline intermittently has now been resolved. BankServ has completed their investigation and everything is back to normal.
Posted Oct 24, 2024 - 15:49 CAT

Investigating

MasterCard Payments Declining Intermittently: We’re experiencing some declines with 3D Secure MasterCard payments. BankServ has let us know that there’s an ongoing issue with MasterCard, and they’re working on it right now.
Posted Oct 24, 2024 - 13:50 CAT
This incident affected: Checkout and 3rd Party Platforms (3DSecure Authorisation - Mastercard).