Community Support Offline on the 25th & 26th December.

Incident Report for PayJustNow

Resolved

Our Support channels will be
Posted Dec 26, 2024 - 18:11 CAT

Monitoring

Dear PayJustNow Community,

Please note that the support channels are offline on the 25th and 26th December. The entire PayJustNow team wishes you and your loved ones a happy and blessed holiday.

We’re here to ensure your shopping experience is seamless, even during high-demand periods like today. To make it easier for you, we’ve prepared extensively, and our digital chat channels are the best way to reach us.

Meet Our Chat Bots -
Iggy: Handles general questions about the PayJustNow App. Use the "Rapid Response" channel to chat with Iggy, or ask to connect to a live agent when needed.
Karabo: For PayStretch - related questions, our innovative feature that lets you stretch payments further. If you don’t see this option yet, stay tuned as we expand availability based on qualification.

AI Bots First: Engage with our bots—they resolve 80% of queries quickly!
Email Support: Send only one email to avoid delays. Reply to our automated response for updates and include your reference number in chats.

Common Issues:
Card Payments Declined: Check your bank app for online shopping settings, or reach out to your bank directly.
Selfie Verification Failed: Ensure your ID is handy for verification.
Single Instalment Only: Use your own verified phone, card, and profile details for full functionality.
We appreciate your patience and understanding as we work to assist everyone with care. Thank you for trusting PayJustNow—we’re committed to making your experience remarkable.

Best regards,
The PayJustNow Team
Posted Dec 24, 2024 - 08:47 CAT