Wallet Withdrawal Failure

Incident Report for PayJustNow

Resolved

We have resolved the issue with wallet withdrawals.
Thank you for your patience.
Posted Jan 14, 2026 - 15:25 CAT

Investigating

We are currently experiencing an issue when processing wallet withdrawals.
Please bear with us as we try to resolve this issue with the bank.
Posted Jan 13, 2026 - 16:11 CAT
This incident affected: 3rd Party Platforms (ABSA Bank).