Phone Lines Unavailable

Incident Report for PayJustNow

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 08:30 CAT

Identified

Our phone lines are currently unavailable. Please use the chat and email function to reach out to our support team - support@payjustnow.com.
We apologise for the inconvenience caused.
Posted Mar 05, 2026 - 08:18 CAT
This incident affected: Support Platforms (Phones).