A brand new PayJustNow just for you!

Incident Report for PayJustNow

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 06:31 CAT

Update

We are continuing to monitor for any further issues.
Posted Apr 10, 2025 - 06:25 CAT

Monitoring

🚀 The new PayJustNow is here!

We’ve rolled out our latest update — and while there were a few minor teething issues (thanks tech gremlins 🙃), everything’s up, running, and ready for you to tap, shop, and go. Please be sure to update your App when prompted to do so.

Thanks for riding it out with us — we truly appreciate your patience and support. 💛

#PayJustNow #AppUpdate #AllSystemsGo
Posted Apr 08, 2025 - 05:38 CAT

Update

We are continuing to investigate this issue.
Posted Apr 06, 2025 - 20:04 CAT

Investigating

We're excited to announce the launch of our new app! During this transition, we may be temporarily offline. We appreciate your patience and understanding as we work to bring you an enhanced experience. Stay tuned for updates!
Posted Apr 06, 2025 - 20:04 CAT
This incident affected: SignUp, Checkout, Core Switching and Consumer Platforms (Web, IOS APP, Android APP, Huawei APP).