This incident has been resolved. Thank you for your patience.
Posted Sep 05, 2024 - 18:47 CAT
Monitoring
A Fix has been implemented, and we will continue to monitor the performance. We are seeing the Visa transactions processing successfully.
A special shout out, with a big Thank-you! 🎈to our consumer users for the assistance you gave us by contacting your bank to get the confirmations, we needed to escalate this to the payment switch appropriately.
Thank you for your patience with us as we navigated through this issue. If you were affected by this issue, please try to make your payment again.
Posted Sep 05, 2024 - 16:40 CAT
Identified
This issue is limited to Visa bank cards, and our payment switch are actively investigating the case with the Visa network and their engineers. We appreciate you for your patience, please subscribe to this status incident and we’ll keep you updated on our progress.
Posted Sep 05, 2024 - 16:18 CAT
Investigating
We've noticed a rise in transactions being declined with the message: "Transaction declined (Invalid Card)."
Banks have informed us that the issue isn't with the cards themselves. Instead, it seems to be caused by an incorrect transaction mode being sent by our payment switch on some of our payments, which is causing these transactions to be flagged incorrectly.
Our team is actively working on resolving this issue. We appreciate you for your patience, please subscribe to this status incident and we’ll keep you updated on our progress.
Posted Sep 05, 2024 - 15:01 CAT
This incident affected: 3rd Party Platforms (ABSA Bank, FNB Bank).