Happy New Year

Incident Report for PayJustNow

Resolved

This incident has been resolved.
Posted Jan 02, 2025 - 08:53 CAT

Monitoring

Happy New Year from the PayJustNow team! We’re taking a short break to celebrate and will be back on January 2, 2025, to assist you with any queries. Thank you for your patience, and have a wonderful start to the new year!
Posted Jan 01, 2025 - 07:43 CAT
This incident affected: Support Platforms (Chat, Email, Phones).