Support Services Temporarily Interrupted

Incident Report for PayJustNow

Resolved

Our support desk is back up; we apologise for the inconvenience caused while our 3rd party service provider worked to resolve the issue.
Posted Dec 05, 2025 - 11:29 CAT

Identified

Our support desk is currently unavailable due to scheduled maintenance. We expect to resume service shortly and apologize for any inconvenience this may cause.
Posted Dec 05, 2025 - 11:10 CAT
This incident affected: Support Platforms (Chat, Email, Phones).