Service desk

Incident Report for PayJustNow

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 15:16 CAT

Identified

We're currently experiencing an Internet outage at the office, which is affecting access to our systems and services. As a result, our Support team is temporarily offline and unable to respond to requests.

We're working to restore connectivity as soon as possible and will provide an update once services are back online.

Thank you for your patience and understanding.
Posted Sep 11, 2026 - 12:24 CAT
This incident affected: Support Platforms (Chat, Phones).