We’re pleased to confirm that all services have been successfully restored following this evening’s scheduled release.
The deployment was completed as planned, and PayUp and the Merchant Portal are now fully operational. The update enables refund processing for Online V2 Checkouts and forms part of our continued improvements to ensure peak trade readiness.
Thank you for your patience and cooperation during the maintenance window.
Kind regards, The PayJustNow Team
Posted Oct 12, 2025 - 20:02 CAT
Monitoring
We are performing a scheduled release on Sunday evening. During this time, some functionality on the PayUp merchant app and the Merchant Portal may be temporarily unavailable.
This release includes enhancements that enable refund processing for Online V2 Checkouts through the current Merchant Portal. The change is an important step in improving peak trade readiness across our systems.
We expect all services to be fully restored by 8:00 PM.
Thank you for your patience and understanding while we complete this essential upgrade.
Kind regards, The PayJustNow Team
Posted Oct 12, 2025 - 19:37 CAT
This incident affected: Merchant Platforms (PayUp APP, Merchant Portal).