Scheduled Debit Run Failure

Incident Report for PayJustNow

Resolved

We have been monitoring payment performance since the fix went in and the issue has been permanently resolved. Thank you for your patience. If you had a payment due this morning, it will be reattempted later today. if you make the payment manually, our system will not attempt to debit again.
Posted Sep 30, 2024 - 10:55 CAT

Monitoring

This issue related to a certificate that expired downstream on our payment switch's network. They have implemented the fix and The issue has been resolved, and transactions are now processing smoothly.

Scheduled debits will be re-run later today, and the system is fully operational for processing new orders and card registrations. We appreciate your patience and understanding during this time.
Posted Sep 30, 2024 - 08:49 CAT

Update

Please note that this will affect new order instalment payments. It is recommended that you subscribe to this incident to get real time updates to let you know when the issue is resolved.

We apologise for the inconvenience, and thank you for your patience and understanding.
Posted Sep 30, 2024 - 07:13 CAT

Identified

We are aware that our scheduled debit run this morning did not process successfully. Our engineers are actively working on resolving the issue, and we will provide further updates as soon as it's been resolved.

Please note, if you received any notifications regarding failed payments, kindly ignore them. We are confident that no payments were attempted, and therefore no bank charges have been incurred.

Please note that this will affect new order instalment payments. It is recommended that you subscribe to this incident to get real time updates to let you know when the issue is resolved.

We apologise for the inconvenience, and thank you for your patience and understanding.
Posted Sep 30, 2024 - 06:09 CAT
This incident affected: Checkout.