Degraded Performance for card payments

Incident Report for PayJustNow

Resolved

Bankserv has confirmed that the earlier issue has been resolved, and they are actively monitoring the system to ensure stability. We apologize for any inconvenience this may have caused. Please feel free to attempt your purchase or payment now.

Thank you for your patience and understanding.
Posted Aug 20, 2024 - 12:05 CAT

Identified

This means that you may experience issues when trying to make payments with your registered card or when adding a new card to your profile.

We understand how frustrating this can be and apologize for the inconvenience. Please consider subscribing to this status update for real-time notifications, so you can complete your purchase or payment as soon as the issue is resolved.
Posted Aug 20, 2024 - 08:45 CAT

Investigating

We're currently aware of degraded performance for card payments due to communication errors with Visa and Mastercard schemes.

Initial checks with our acquirers have confirmed that Bankserv is still experiencing issues on their end. We are awaiting further updates from both the acquirers and Bankserv as their teams actively investigate the situation.
Posted Aug 20, 2024 - 08:44 CAT
This incident affected: 3rd Party Platforms (ABSA Bank, Capitec Bank, FNB Bank, Standard Bank, Nedbank Bank) and Checkout, Core Switching.