Capitec Card Transactions

Incident Report for PayJustNow

Resolved

The issue affecting Capitec Mastercard transactions has been resolved. Customers should now be able to complete payments successfully.

If you still experience a “limit exceeded” error, please check that your online payment settings are enabled and that your online spend limit is high enough to cover the transaction.

Thank you for your patience while this was resolved.
Posted Sep 19, 2025 - 08:22 CAT

Identified

We are aware that some Capitec Mastercard transactions are currently failing with a “limit exceeded” error. The issue has been identified on the bank’s side, and we are actively working with Capitec to get it resolved as quickly as possible.

In the meantime, we recommend using an alternative card issued by a different bank to complete your transactions.

We apologize for the inconvenience and appreciate your patience.
Posted Sep 18, 2025 - 13:46 CAT

Investigating

We are aware of an issue affecting some Capitec cardholders where transactions return a “limit exceeded” error. This appears to be a bank-related issue, and our team is actively investigating with Capitec.

In the meantime, please double-check that your card is set up for online payments and that your online spend limit is high enough to cover the transactions you are attempting. If the transactions still fail, please use an alternative card issued by a different bank.

Thank you for your patience.
Posted Sep 18, 2025 - 11:44 CAT
This incident affected: 3rd Party Platforms (Capitec Bank).