🚨 Service Alert 🚨

Incident Report for PayJustNow

Resolved

This incident has been resolved, and all services restored. Thank you for your understanding. πŸ™
Posted Feb 15, 2025 - 10:54 CAT

Update

βœ… Service Update βœ…

The issue has been identified and resolved. Our service desk is now fully operational, and all chat and email support channels are back online.

Thank you for your patience! πŸš€
Posted Feb 15, 2025 - 10:54 CAT

Investigating

Our service desk is temporarily offline as our service providers investigate the issue. At this time, all chat and email support channels are unavailable. We appreciate your patience and will provide updates as soon as more information becomes available.

Thank you for your understanding. πŸ™
Posted Feb 15, 2025 - 10:30 CAT
This incident affected: Support Platforms (Chat, Email).