Good news! The connection issues we were experiencing earlier due to an unstable third-party service have now been fully resolved. Everything should be back up and running as normal.
Thank you so much for your patience.
Posted Nov 18, 2025 - 16:49 CAT
Monitoring
Update from Cloudflare - A fix has been implemented and they believe the incident is now resolved.
Posted Nov 18, 2025 - 16:44 CAT
Update
Updated from Cloudflare: The issue has been identified, and a fix is being implemented
Posted Nov 18, 2025 - 15:15 CAT
Identified
We’re currently experiencing intermittent connection issues due to instability with one of our third-party service providers. This may cause the app to load slowly or disconnect at times. We really appreciate your patience and understanding during this time.
Posted Nov 18, 2025 - 14:38 CAT
This incident affected: SignUp, Checkout and Consumer Platforms (Web, IOS APP, Android APP, Huawei APP).