Customer Service Disruption

Incident Report for PayJustNow

Resolved

The connection issue has been resolved.
The PayJustNow team will be back online on 8 February.
Thank you for your patience.
Posted Feb 07, 2026 - 17:41 CAT

Identified

We apologize for the disruption. Due to a connection issue, support channels are currently down. Our team is aware of the issue and is working urgently to restore service. Thank you for your patience.
Posted Feb 07, 2026 - 15:55 CAT

Investigating

We apologize for the disruption. Due to a connection issue, support channels are currently down. Our team is aware of the issue and is working urgently to restore service. Thank you for your patience.
Posted Feb 07, 2026 - 15:38 CAT
This incident affected: Support Platforms (Chat, Email).