PayStretch systems maintenance

Incident Report for PayJustNow

Resolved

Scheduled maintenance on our PayStretch product systems has been completed. PayStretch facilities are now fully operational and can process transactions as normal.

Our 3-instalment Buy Now, Pay Later (BNPL) service remains fully available.

Thank you for your patience during the maintenance window.
Posted Apr 27, 2025 - 11:08 CAT

Monitoring

Our PayStretch product systems are currently undergoing scheduled maintenance and are expected to be back online by 11:00 AM.
Please note that our 3-instalment Buy Now, Pay Later (BNPL) service remains fully operational.

Thank you for your patience and understanding.
Posted Apr 27, 2025 - 08:53 CAT
This incident affected: Checkout.