Scan to Pay In-store

Incident Report for PayJustNow

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 05:36 CAT

Update

🔧 Fix Alert + 🎉 Fresh Update Incoming!

We’ve squashed the bug 🐞 and polished things up — our Scan to Pay feature will be up and running in the new app version 3.0.1, landing shortly in your app store.

📲 Update coming soon — keep an eye out!

Thanks for your patience. You’re the best kind of humans 💛
#PayJustNow #AppUpdate #ScanToPay
Posted Apr 07, 2025 - 14:30 CAT

Identified

We’re currently aware of an issue affecting the Scan to Pay functionality, and our tech team is already on it.

In the meantime, please make sure your PayJustNow app is updated to the latest version—this often helps resolve hiccups and ensures you’ve got all the latest fixes and features.

Thanks for your patience while we get this sorted.
Posted Apr 07, 2025 - 11:23 CAT
This incident affected: Checkout.