Our switch-over to the secondary acquiring bank channel has been completed, and we are seeing transaction success rates normalising. Please try to process your order/payment again when you are ready. Thank you for your patience.
Posted Sep 10, 2024 - 17:01 CAT
Identified
The issue has been identified to be limited to the acquiring bank channel. (The bank we use to collect the debits). We are switching over to our secondary acquiring bank and will update here once done.
We apologize for the inconvenience. Please consider subscribing to this status update for real-time notifications, so you can complete your purchase or payment as soon as the issue is resolved.
Posted Sep 10, 2024 - 16:55 CAT
Investigating
The Network payment switch used to process card payments have been affected by a network failure. This means that you may experience issues when trying to make payments with your registered card or when adding a new card to your profile.
We understand how frustrating this can be and apologize for the inconvenience. Please consider subscribing to this status update for real-time notifications, so you can complete your purchase or payment as soon as the issue is resolved.
Posted Sep 10, 2024 - 16:25 CAT
This incident affected: 3rd Party Platforms (ABSA Bank, Capitec Bank, FNB Bank, Standard Bank, Nedbank Bank) and Checkout, Core Switching.